hitask.com | Sign Up | Log In to Hitask

Cant login into hitask, on login page I see arabic letters


(Vojtech Sokol) #1

I am experencing the problem with arabic letters (or what is it) on login page last few weeks, but now I cant login… Please note that I am from Czech republic, we use standard latin letters :slight_smile: Please fix it asap, I cant use this service until that…

edit: I tried other browsers or clear cookies…


(Roman Roan) #2

Sorry about the problem.
Please clear your browser cookies and try again.
You can also open Hitask.com home page and un language selection at the bottom of page select English or any other language.
If you have any issues please contact us using chat on the website.


(Vojtech Sokol) #3

I can login now, but that problem with arabic language still persists, on homepage I have “english” selected… I tried it in different browsers - edge, chrome, firefox, still the same, its definetely not a cookies problem… I think you are detecting czech language somehow wrong… in the task app is everything ok, just the login/signup page