Synchronising to calendars (CalDAV)

It has taken a long time for me to get CalDAV set up for both macOS and iOS – I think the instructions need updating (not to mention fixing links which aren’t links and updating the ancient iOS screenshots!).

For anyone else having trouble, the following worked for me.
NOTE ignore the use of the letter X in places. This was to get around a silly limitation that wouldn’t let me post!

iOS

macOS

  • the Xwebcal:// link given in the Hitask Data menu didn’t seem to work. In macOS Calendar, go to Calendar > Add Account > Other
  • Change Account Type to Advanced
  • Fill in the username and password
  • Separate the URL into the two boxes: Server Address (secure.hitask.com or maybe Xhttps://secure.hitask.com in this instance) and Server Path (/calendar/[username])
  • Set the port to 443
  • Other settings as default: Use SSL ticked and Kerberos unticked.

If you want items to appear in the Reminders app, go to Calendar > Accounts (or access the same thing via System Preferences), find the hits entry and tick the box for Reminders.

Also, remember to use your username, not your email address! Check Settings > My Account in Hitask if you can‘t remember it.

Hello Jamie,

Thank you for the feedback! We will update the instructions shortly.